1

Cisco emite parche crítico para conmutadores Nexus

La empresa Cisco ha publicado la actualización de software para los interruptores para eliminar las credenciales codificadas en esos equipos.

Las actualizaciones de software para sus interruptores Nexus 3000 y 3500 con el fin de eliminar una cuenta administrativa por defecto con credenciales estáticas que podrían permitir a un atacante remoto comprometer dispositivos.

Los interruptores de la plataforma contienen una cuenta root con una contraseña estática que se puede acceder de forma remota y que podrían permitir a un atacante comprometer los dispositivos.

“La cuenta se crea durante la instalación del software Cisco NX-OS que se ejecuta en estos interruptores y no puede ser cambiado o eliminado sin afectar la funcionalidad del sistema”, dijo Cisco en un aviso.

La compañía tiene este problema como crítico porque la autenticación con esta cuenta puede proporcionar a los atacantes acceso a una shell bash con privilegios de root, lo que significa que puede controlar completamente el dispositivo.

Nueva batalla

Un factor que podría limitar los ataques es que en la mayoría de los comunicados NX-OS, la cuenta predeterminada sólo se puede acceder a través de Telnet, que está desactivado por defecto. La excepción es la Nexus 3500 Platform Switches cuya liberación corre en el NX-OS Software 6.0 (2) A6 (1), donde también se puede acceder a la cuenta través de SSH (Secure Shell).

Los dispositivos afectados son: Nexus 3000 Series Switches que corren en NX-OS 6,0 (2) U6 (1), 6,0 (2) U6 (2), 6,0 (2) U6 (3), 6,0 (2) U6 (4) y 6.0 (2) U6 (5) y los interruptores de la PlataformaNexus 3500 que corre en NX-OS 6,0 (2) A6 (2), 6,0 (2) A6 (3), 6,0 (2) A6 (4), 6,0 (2) A6 (5) y 6.0 (2) A7 (1).

Cisco ha proporcionado las versiones parcheadas para todas estas equipos pero la compañía aconseja a los clientes actualizar a NX-OS 6.0 (2) U6 (5a) para los interruptores Nexus 3000 y 6.0 (2) A7 (1a) o 6.0 (2) A6 (5a ) para la serie Nexus 3500.

¿Por qué? Porque estas versiones también contienen parches para otras dos vulnerabilidades de alto impacto que podrían conducir a condiciones de denegación de servicio.

Las otras vulnerabilidades

Uno de esos defectos pueden ser explotado mediante el envío de un paquete TCP específico para un dispositivo afectado en una sesión TCP que está en una estado TIME_WAIT. Esto haría que la pila TCP vuelva a cargar lo que ocasiona una denegación de servicio.

La vulnerabilidad afecta al software NX-OS que se ejecuta en el Nexus serie 1000V, Serie 3000, Serie 4000, Serie 5000, los conmutadores de la serie 6000 y 7000 así como el Cisco Unified Computing System (UCS).

La segunda vulnerabilidad puede ser explotada mediante el envío de un paquete diseñado de SNMP (simple Network Management Protocol) para un dispositivo afectado, lo que provocaría que el dispositivo del servidor SNMP se reinicie. Hacer esto en repetidas ocasiones podría llevar un reinicio completo del sistema.

Esta vulnerabilidad afecta a los interruptores de las plataformas Nexus 5500, Cisco Nexus 5600 y Nexus 6000 Series Switches Cisco que corren en el NX-OS Software versión 7.1 (1) N1 (1).